How do you ensure SalesLoft Owner always equals Salesforce Owner?

Comments

2 comments

  • Avatar
    Matt McCandless

    So I have this setting set up but I'm still getting different owners. How/why is this not the default function? 

    0
    Comment actions Permalink
  • Avatar
    Darcy Groom

    Hey Matt - I would recommend ensuring that all the following are true in the order described. If you send some examples over to your Customer Success team, they can walk through steps 3-5 with you or help you create a ticket with support if they are unable to track down the issue.

    1. Owner CRM ID is correctly mapped in Field Configuration.
    2. All users are mapped in User Management.
    3. Data is syncing between the two without errors. Check this in your Salesforce Sync logs. Hint: you can filter down to a specific record or filter by successes/failures. 
    4. Automation Rule is firing. You can check the Automation Rule logs here, filter to your specific automation rule, and review the logs to see details on the record for which the rule is firing.
    5. For the Cadence Assignee, verify that the cadence you are looking at is a Team cadence and keep in mind that this setting only comes into play when the original Team Cadence Assignee is also the original Person Owner.

    Also - keep in mind for the set up Ryan describes above that this Rule is only firing when Owner CRM ID has changed. So if you set this rule up it will not fire for all current records automatically, only for new changes moving forward. There are ways to trigger the change if you do want it to fire retroactively.

    The reason these are not default function is that some sales team have custom and/or complex workflows for their sales team and sales engagement strategy. For example, someone in an AE role may own the contact in SFDC, but the BDR is the one to own and/or work the contact in SalesLoft. Using these configuration settings give you more control over how you wish to update ownership/assignee.

    0
    Comment actions Permalink

Please sign in to leave a comment.